InstallationError

Topics: Web Client Software Factory, User Forum
Mar 20, 2007 at 10:14 AM
Hi friends, i got some weird error as below :
Unable to get installer types in the c:\program files\Microsoft Visual Studio 8\Common7\ide\PublicAssemblies\WebClientFactoryPackageInstaller.dll assembly.-->Unable to load one or more of the requested types.Retrieve the LoaderExceptions property for more information. I have follow exactly the instruction of steps to install WebClientFactory but cant go futher with this error.Please guide me what i should do next.
Before i go futher friends, Do i need Microsoft Visual Studio Team Suite installed in order to install this app? Currently I'm using MS Visual Studio 2005 Professional Edition.

Thanks in advanced
Mar 20, 2007 at 2:08 PM
You don't need to have Team Suite, did you install the GAT & GAX properly.

See http://www.codeplex.com/websf/Wiki/View.aspx?title=Installing%20the%20Web%20Client%20Software%20Factory&referringTitle=Home for installing
Mar 21, 2007 at 4:40 AM
Yup i did follow the instruction as well. But the same problem.Do i need to install all the package in the same directory?
Thanks
Coordinator
Mar 21, 2007 at 3:44 PM
Edited Mar 21, 2007 at 4:21 PM
mugun,

I had the same error on my VPC. For me GAX and / or GAT was not running correctly. To solve the problem I:

Uninstall GAT first and then GAX. Reinstall GAX and then GAT and then installed the Web Client Software Factory. Then everything worked fine. Let me know if this works.

By the way, the devs our team - WCSF - joked that I anonymously made your post so they would have to help me figure out the problem.

blaine
Mar 21, 2007 at 5:29 PM
blainew

I have the same problem with 'Web Client Software Factory' and 'Web Service Software Factory'. I reinstalled GAT and GAX (with and without reboot) without success.

Do you have other suggestions?
Mar 21, 2007 at 7:06 PM
I have tried to compile the source code and it looks like it needs GAX 1.0. It does compile if with GAX 1.2 but you have to remove the references to GAX 1.0 and add the references to GAX 1.2.
Is it possible to get the older versions of GAX and GAT?
Mar 23, 2007 at 4:32 AM
Edited Mar 23, 2007 at 4:33 AM

blainew wrote:
mugun,

I had the same error on my VPC. For me GAX and / or GAT was not running correctly. To solve the problem I:

Uninstall GAT first and then GAX. Reinstall GAX and then GAT and then installed the Web Client Software Factory. Then everything worked fine. Let me know if this works.

By the way, the devs our team - WCSF - joked that I anonymously made your post so they would have to help me figure out the problem.

blaine


blaine,

I have tried exactly as you said but the same error occured "Unable to get installer types in the c:\program files\Microsoft Visual Studio 8\Common7\ide\PublicAssemblies\WebClientFactoryPackageInstaller.dll assembly.-->Unable to load one or more of the requested types.Retrieve the LoaderExceptions property for more information"

My GAX & GAT version Feb 2007 CTP and my WCSF Version Jan 2007. Any other idea? I'm sorry for your collegue suspect you was me. :)
Mar 31, 2007 at 2:19 PM
WOHOOO....

I finally succeded in installing WCSF.
It looks like WCSF is compiled to use a specific version of GAX.
This should be fixed by adding <publisherPolicy apply="no" /> to machine.config either on all assemblies or the individual assemblies
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<publisherPolicy apply="no"/>
</assemblyBinding>
</runtime>
</configuration>

(on my machine the dependend assemblies were configured for .net 1.1 so I copied them to the .net 2.0 section)
Feb 15, 2008 at 5:39 AM
I got the same error on my machine but I was able to resolve it successfully by uninstalling -

  1. GAT
  2. GAX

Somehow, it has to be uninstalled in the above order otherwise it gives weird errors.

And, then by installing the following in the specified order -

  1. GAX
  2. GAT
  3. WCSF

I've both VS.NET 2005 and VS.NET 2008 Professional editions installed on my machine. I choose to install GAX on VS.NET 2008 Professional the first time(it asks which version of VS.NET one wants to install GAX on, via Radio buttons on the first screen) and got the WebClientFactoryPackageInstaller error while installing WCSF. The time I choose VS.NET 2005 while installing GAX and everything worked fine!

Hope this helps,
Tarun
http://tarunkohli.blogspot.com