Error adding a new business module VB to a web site wap application

Topics: Web Client Software Factory, Project Management Forum, UIP Application Block discussion, User Forum
Jul 22, 2008 at 5:12 PM

Hello,  I am Working with VS 2008, I Have a Wap web site Project, but  when I try to add a new business module to my  Project ,  It presents this error: “Microsoft.Practices.RecipeFramework.RecipeExecutionException: An exception occurred during the binding of reference or execution of recipe CreateModuleVB. Error was: The following arguments are required and don't have values: RootNamespace, ModuleNamespace, ModuleTestProjectNamespace, ModuleInterfaceProjectNamespace, ModuleWebsiteNamespace. Can't continue execution.. You can remove the reference to this recipe through the Guidance Package Manager.   at Microsoft.Practices.RecipeFramework.Recipe.ThrowIfRequiredArgumentsAreNull(IDictionaryService arguments)   at Microsoft.Practices.RecipeFramework.Recipe.Execute(Boolean allowSuspend)   at Microsoft.Practices.RecipeFramework.GuidancePackage.Execute(String recipe, IAssetReference reference, IDictionary arguments)   at Microsoft.Practices.RecipeFramework.GuidancePackage.ExecuteFromTemplate(String recipe, IDictionary arguments)   at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.UnfoldTemplate.ExecuteRecipe(Boolean executeActions)   at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.UnfoldTemplate.RunFinished()”

It ´s not normal cause I have seen how it works in another machines, I reinstalled WCSF and enterprise library 4.0 and I continue with the same error, I reinstalled VS 2008 and now I can’t add any project with WCSF cause all reference appear be lost…  I reinstalled WCSF and it’s the same problem, please If someone have the same error and solved it, I will hope,  you give me an answer!!

Hazel

Jul 22, 2008 at 6:47 PM
Did you install the guidance package?

Chester
Jul 22, 2008 at 9:49 PM
No I did not, I am goin to do it!!
Jul 22, 2008 at 10:45 PM

Yess it works!! the last time I uninstalled WCSF in control panel was guidance package like it was installed but really, it wasn't working, I choose change in control panel and reinstalled  guidance package cause I coud't uninstall cause an error..... I reinstalled  Enterprise Library and WCSF, and now  I have no problem!!

Thanks a lot Chester

Hazel

 

Jul 7, 2009 at 10:39 PM

After installing the guidance package, it didn't work for me.

But after adding GlobalSection to sln file it worked.

Add this to sln file:
GlobalSection(ExtensibilityGlobals) = postSolution
  RootNamespace = WebClient
  IsWCSFSolution = True
 EndGlobalSection

May 26, 2011 at 6:26 PM

I was able to finally add a new module.  However, there is an additional step I had to follow.  My project has a folder containing all the dll's.  This folder was named SharedBinaries.  But when the Guidance package manager tries to build a web site, it is looking for the 'library' folder.  I renamed my SharedBinaries to library *and* added the GlobalSection entry to the .sln file.