Webservice software factory receipe does not show up

Topics: Web Client Software Factory, User Forum
Apr 12, 2007 at 2:46 AM

I have enabled the WCSF Solution with following attributes - IsSolution =true as mentioned in reference implementation and reloaded the solution. the receipe to add web service factory does not show up. please help me with the same.
Apr 12, 2007 at 10:59 PM
Did you read either of these?
Apr 15, 2007 at 3:27 AM
Thanks I looked into it and it worked.
May 2, 2007 at 10:49 PM
I have followed the direction for using the WCSF with an existing web site project and am not able to use the Add Business Module template. When I right click on the Modules solution folder I don't get the Web Client Factory context menu. When I go to Tools -> Guidance Package Manager I have the Add Page Flow Definition and Add View recipies and those are enabled (the Execute button is enabled). However, when I click on any of the templates (Add Business Module, Add Foundational Module, Add Page Flow Project) the execute button is disabled. If I click on a folder in my web site I get the Web Client Factory to add a view with a presenter. Is there something I can do to get the Add Business module recipe to work?

May 3, 2007 at 3:01 AM
As a note I've tried deleting my gpState and suo files but that didn't help. Some folks on the Service Factory group had this help them with a similar issue with their recipies not showing. I'm bummed out, if I can't get this to work soon I may have to just revert my changes and not use WCSF :(
May 3, 2007 at 3:53 AM

Just enabling the Guidance Package on any project with no other changes will give you what you described above.

Getting the module-related recipes to show up takes about 1 minute. Just modify the SLN file per Michael's post and add a Modules Solution Folder. That alone will activate the module recipes when you right-click on the folder. It won't necessarily make them work, however. You need to make all the other changes per Michael's post to get the application to work as a whole.

It is a pain to do, but I can confirm that the instructions indeed work.




David Hayden
Microsoft MVP C#
May 3, 2007 at 4:31 AM
I've walked through all the steps and verified them multiple times. I'm probably overlooking the same thing every time. Some things to note are:

The add view with presenter recipe works (or at least is visible, haven't used it yet because I haven't been able to add a business module)

I've added this to the sln file in the Global section:

GlobalSection(ExtensibilityGlobals) = postSolution
RootNamespace = IMS
IsWCSFSolution = True

I have a modules solution folder that is defined as the following in the sln file:

Project("{2150E333-8FDC-42A3-9474-1A3956D46DE8}") = "Modules", "Modules", "{26E53481-DE85-49AD-B795-62C99E531DAA}"
ProjectSection(WebsiteProperties) = preProject
Debug.AspNetCompiler.Debug = "True"
Release.AspNetCompiler.Debug = "False"

I've compared that project definition to one in a test solution where the business modules recipe does appear and the only difference is the Guid and of course the location of the project definition in the sln file (my solution has over 50 projects).

I do have other solution folders besides the Modules and WebSites folder, but I've tested this scenario in a test solution so I don't think this is the solution.

I'll go verify the directions again - maybe I'll find that one tiny thing I missed this time.
May 3, 2007 at 7:06 AM
Yeah, I have followed those directions and verified my steps several times.

The last interesting thing that I have noticed is that in the Tools -> Guidance Package Manager dialog the three options that don't work are listed as templates whereas the two recipes (Add view with presenter, Add page flow definition) work. So the issue is specific to the templates.
May 3, 2007 at 7:16 AM
Also, when I enter the add view with presenter dialog, it knows that there is a shell module. So it knows a module exists, it just won't let me add a new module.
May 3, 2007 at 7:19 AM
Oh, and I'm on Vista (with VS SP1 and the vista patch). Has WCSF been tested on Vista?
May 3, 2007 at 7:13 PM
Is there somebody on the WCSF team that can identify the 3 or so things that need to be in place in order for the templates to be enabled? That way I can verify that those things are in place.
May 24, 2007 at 3:50 AM
bump. would be nice to get wcsf usable...
Jun 1, 2007 at 2:55 PM
I'm having a similar problem with the Add Business Module recipe. The Development Website no longer appears in the "Web Site" drop down, and therefore the Finish button remains disabled.

I have read through Michaels two links above and checked the solution file, and can't find anything else that may work.

I created the solution using the factory a few weeks ago as a pilot. It has worked fine and I have developed a number of business modules. The team is ready to go ahead with the development so I checked it in to TFS a few days ago. We had a bit of an issue with TFS falling over in a heap involving database corruption and a host of other issues which I've now resolved. Today I loaded the web client from source control and alas I am no longer able to create business modules.

Any help would be greatly appreciated as it's been hard convincing the newbie team to use WCSF and I could really do with it going smoothly.

Many thanks.