Reference Implementation project

Topics: User Forum
Jan 17, 2007 at 2:49 AM
When compiling the reference implementation project I get these compile errors:

Error 272 Cannot update project reference 'Infrastructure.Testing.UI'. Failed to create the bin directory. Unable to add folder 'Bin' to the Web. Cannot create the folder 'Bin'. A file with that name already exists. C:\...\WebUI\
Error 273 The type or namespace name 'Practices' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 21 17 C:\...\WebUI\
Error 274 The type or namespace name 'Practices' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 22 17 C:\...\WebUI\
Error 275 The type or namespace name 'Practices' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 23 17 C:\...\WebUI\
Error 276 The type or namespace name 'Practices' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 24 17 C:\...\WebUI\
Error 277 The type or namespace name 'Practices' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 25 17 C:\...\WebUI\
Error 278 The type or namespace name 'Commercial' does not exist in the namespace 'GlobalBank' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 26 18 C:\...\WebUI\
Error 279 The type or namespace name 'Infrastructure' does not exist in the namespace 'GlobalBank' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 27 18 C:\...\WebUI\
Error 280 The type or namespace name 'WebClientApplication' could not be found (are you missing a using directive or an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 31 46 C:\...\WebUI\


I followed the installation instructions and didn't receive any errors during installation.
It also looks like that there are no references marked as unresolved in the project.

Any help is much appreciated.

Thanks
Rainer
Jan 17, 2007 at 8:27 AM
Did you open the whole solution or just the website-project?
Jan 17, 2007 at 8:52 AM
I opened the whole solution
Jan 17, 2007 at 9:28 AM
Delete the bin file in the website. I had the same problem @ home.
Jan 17, 2007 at 8:43 PM
Thanks for your help.

I've deleted the bin file, but no luck.

However I know understand one of the error's that says that the Bin folder cold not be created, because there is already a file with that name in the directory. I am now trying to find where this is defined, because I think a dll should be created by the compile which is stored in the Bin folder. The other error's may be follow on errors.
Jan 17, 2007 at 8:57 PM
Ok, some progress:

I've done the following:

- deleted the Bin file again
- turned off building on all Unit test projects
- created a bin directory in the website.

Now I can see a lot of assemblies being copied into the Bin folder and the number of error messages has dropped.
This is what is left:

Error 1 The type initializer for 'Microsoft.Practices.PageFlow.WorkflowFoundation.Activities.PageFlow' threw an exception. 0 0
Error 2 Cannot update project reference 'Infrastructure.Testing.UI'. Failed to create the bin directory. C:\...\WebUI\
Error 3 The type or namespace name 'ElectronicFundsTransfer' does not exist in the namespace 'GlobalBank.Commercial.EBanking.Modules' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 26 46 C:\...\WebUI\
Error 4 The type or namespace name 'Infrastructure' does not exist in the namespace 'GlobalBank' (are you missing an assembly reference?) C:\WCSF Source\RI1\Source\Infrastructure\WebUI\App_Code\ElectronicBankingApplication.cs 27 18 C:\...\WebUI\

Don't understand why this (Infrastructure.Testing.UI) is still showing up although I've turned of the build flag.

Jan 18, 2007 at 5:03 AM
Have you tried the solution without the tests?