Guidance Recepies not available

Topics: Web Client Software Factory
Jan 3, 2007 at 11:37 AM
The only guidance recepy I have available is the Add View (with Presenter).

Do I have to clean up anything (besides uninstalling the previous version and installing the new one)?
Jan 3, 2007 at 12:38 PM
I have the same situation, and this is the first time I've installed Guidance package (compiled from the latest drop 2007-01-02).

But this recipe doesn't work for me, I get this error:

"An exception occurred during the binding of reference or execution of recipe CreateView. Error was: An error happened while calling the value provider or evaluating the default value of argument ModuleInfos..
You can remove the reference to this recipe through the Guidance Package Manager."

Jan 3, 2007 at 2:01 PM
I'm not getting any exception because the receby show up but doesn't work.

I'm guessing it can't find any module in the solution.
Developer
Jan 4, 2007 at 12:33 AM
Are you running the recipes in a new Web Client Solution created with the latest drop or is it an old solution?

If you are running the recipes in an old solution, can you please try running them in a new Web Client Solution generated with the latest drop and post the results?

Please take into account that the only recipe you can execute in the Web site is the Add View (with presenter). The following recipes
- Add Business Module
- Add Foundational Module
- Add Page Flow Project (WF)
can only be executed in solution folders.
And the Add Page Flow (WF) recipe can only be executed in a page flow project.
What recipes do you see if you right-click a solution folder? No one?

Thanks,
Mariano Szklanny
http://staff.southworks.net/mariano
Jan 4, 2007 at 8:12 AM
When i selected the node Modules i get the following reciepes:

Add Business Module...
Add Foundational Module...
Add Page Flow Project (WorkFlow Foundation)...

How i got to work.

I compiled the Guidance Package

Selected Tools -> Guidance Package Manager -> Enable/Disable Packages...

Checked Guidance Package Development

Clicked Button OK
Clicked Button Closed

Right Clicked Project Package WebClientFactoryPackage

Selected Unregister Guidance Package ... Waited for the function to finish.

Right Clicked Project Package WebClientFactoryPackage again

Selected Register Guidance Package ... Waited for the function to finish.

No it worked like a charm.
Jan 8, 2007 at 12:48 AM
I can't make it work with the current version of the reference application.

Probably due to the fact that I had previous versions installed (and uninstalled) before.

Any tips?
Jan 8, 2007 at 9:08 AM
Sorry, no tip here.

I had it installed previously too, but i didnt get any problems.

Benny
Mar 14, 2007 at 4:57 PM
I've still got problems with disabled recipes
Coordinator
Mar 16, 2007 at 3:07 AM
I think a few of the recipes (Add business module and add foundational module) only work on Solution Folders. Could that be why you do not see them?
Mar 16, 2007 at 8:48 AM
Nope that's not the problem.

After I start a new Web Client Solution (WAP) then there is only the option of
creating Views (With Presenter).

PS: Could somebody explain where the guidance packages are registered, I couldn't
install the new february CTP of the GAT/GAX, because the WAP Guidance was still
SOMEWHERE on my computer. I Was forced to go back to my clean GHOST image, which
wasn't so bad after all ;-)
Mar 18, 2007 at 9:30 PM
There's a comment on Tom Hollander's blog that might help you find where packages are registered here;

http://blogs.msdn.com/tomholl/archive/2006/06/24/645882.aspx#648815

Hope that helps.

Simon
http://www.dotnetblogs.co.uk/