I find very intuitive naming convention like this:
Events - <action verb> - SomethingHappened
Event firing methods - On<action verb> - OnSomethingHappened
Using this convention, PageFlowHttpModule class should have a PageFlowAbandoned event OnPageFlowAbandoned should be the method that fires the PageFlowAbandoned event.
At least that's what I read somewhere, sometime ago.