Viewing the CHM content

Topics: User Forum
Oct 11, 2006 at 5:15 PM
If you see the message, "Page cannot be displayed" or "The address is not valid" in the content page of the CHM, try the following:

1. Right-click the CHM file, and then click Properties.
2. Click Unblock.
3. Double-click the .chm file to open the file.

See for related information.

Oct 20, 2006 at 2:52 AM
Hi timber,

I am using Windows Vista RC2 and the two solutions you provided are not available (e.g. there is no 'unblock' option). Is there any IE7 option setting I should investigate that might allow me to see CHM files without getting "Navigation to the webpage was canceled" and/or "The address is not valid" in the right-hand pane. I get the content tree in the left-hand pane okay. But any of the selections therein gives me "The address is not valid" in the right-hand pane.

I hope you can help.

Regards, hmeijeri.
Oct 20, 2006 at 5:12 PM
I'm running Vista RC2 as well, and I think I figured out what is going on.
I downloaded to zip file to my computer, so I had the same starting point as anyone else (who is not part of the dev team). If I just use Windows Explorer to browse inside the ZIP file, I get the scenario that you described, and there is no "Unblock" option. Vista is doing its job, and keeping us safe from bad content from the internet. In this case, we trust the content, and there are two solutions:

1. Right-click on the ZIP file, and select Properties, and click Unblock. This will unblock the zip file and its contents. This will allow you to either extract all the contents and have all of it unblocked, or you can browse into the ZIP file and open the unblocked CHM from there.
2. Extract the zip file to a folder on your hard drive, and then just unblock the extracted CHM file. You may have to unblock other content as well, so I recommend option 1.

If this does not help, please let us know.

I'll see if I can get the instructions going forward to include this information.
Oct 24, 2006 at 11:01 PM
there was the same problem on my machine.
the help file just displayed the error.
the unblock did'nt work, as it seems, it didn't save it (the warning window came again when i opened it afterwards, and in the properties the flag was set again.) what helped, was copiing the file and then unblock it. funny behaviour. but thanks for the tip.
Nov 15, 2006 at 7:00 AM
It works for me.

Thanks for the info