Telerik RadGrid Binding and ObjectContainerDataSource

Topics: Web Client Software Factory
Aug 3, 2007 at 9:28 PM
Is anyone using the Telerik RadGrid with the ObjectContainerDataSource?

I'm trying to utilize it and it appears that the RadGrid is not allowing the overrides for the ObjectContainerDataSource for insert, delete and updates. All of them never fire even though they are defined in the page init.

Seems like somthing weird is going on with the RadGrid.

If you have gotten it to work correctly, can you give some hints on what settings you used to get it to work? I'm stumped at this point.

Thanks.
Aug 8, 2007 at 5:48 AM
I use the Telerik RadGrid, but write custom code for the insert, update and deletes.

Have you tried posing this question on the Telerik forums ?
Aug 10, 2007 at 2:25 PM
Hi! Just as a FYI (you probably have seen this, but for others who may come here to read this), here’s a thread from Telerik’s forums where this is discussed.

Luciano G. Panaro
http://staff.southworks.net/lpanaro
Aug 17, 2007 at 1:15 PM
So you are using the advanced binding instead of simple binding? I'm just trying to get a simple binding to work but it loses all the data for just catching the SelectedItems from the grid. I'm not adding, deleteing, etc. Just selecting. I would prefer to utilize the way that WCSF is using the objectcontainerdatasource. It will be alot more coding to do but I guess advanced binding may be the only option unless there is another 3rd party control that will work correctly.

BTW, on your screen designs, I am utilizing a master page with a content page that is inheriting from a base page. The grid loses all data for some reason and I can't seem to find the problem. I am using Teleriks new AjaxManager in the masterpage. Any ideas or thoughts on where to find the possible problem?


jsbbs wrote:
I use the Telerik RadGrid, but write custom code for the insert, update and deletes.

Have you tried posing this question on the Telerik forums ?