Error while creating a Solution with WAP

Topics: Web Client Software Factory
Aug 1, 2007 at 2:52 PM
Hi,

I’m trying to create a Web Client Solution that uses the Web Application Project (WAP) using the Solution templates provided by the WCSF (June) and I get an Exception after pressing on Finish button. I tried with both languages (C# and VB) and I got the same result.

Actually I’m just doing this:

1. Selecting the Web Client Solution (C#, WAP),
2. Clicking OK button (leaving the default solution’s name), and
3. Clicking Finish button (without changing the namespace).

After that I get the following message:

Project Template Wizard
A problem was encountered creating the sub project ‘$WebUIProjectName$’. The project file ‘C:\Documents and Settings\MyUserName\Configuración local\Temp\g5z1aytu.ek0\Temp\DevelopmentWebSite.csproj’ cannot be opened.
The project type is not supported by this installation.

Then I click OK and it shows this Exception:

Microsoft.Practices.RecipeFramework.RecipeExecutionException: An exception occurred during the binding of reference or execution of recipe CreateWebClientFactorySolutionWAPCS. Error was: The following arguments are required and don't have values: WebUIProject. Can't continue execution..
You can remove the reference to this recipe through the Guidance Package Manager.
at Microsoft.Practices.RecipeFramework.Recipe.ThrowIfRequiredArgumentsAreNull(IDictionaryService arguments)
at Microsoft.Practices.RecipeFramework.Recipe.Execute(Boolean allowSuspend)
at Microsoft.Practices.RecipeFramework.GuidancePackage.Execute(String recipe, IAssetReference reference, IDictionary arguments)
at Microsoft.Practices.RecipeFramework.GuidancePackage.ExecuteFromTemplate(String recipe, IDictionary arguments)
at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.UnfoldTemplate.ExecuteRecipe(Boolean executeActions)
at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.UnfoldTemplate.RunFinished()

Anybody knows what is going on? Any clue?

Regards,

Andres Llanos
Aug 1, 2007 at 5:20 PM
Edited Aug 1, 2007 at 5:27 PM
Hi Andres!

Can you create a standard WAP application? (without using WCSF)

Maybe, you don't have Web Application Projects support.
Please, read the last message of this post (is a similar problem):
http://www.devnewsgroups.net/group/microsoft.public.dotnet.framework/topic49512.aspx

Try installing the Microsoft® Visual Studio® 2005 Team Suite Service Pack 1


Support for Web Application Projects is now a feature of Visual Studio 2005 Service Pack 1. A separate add-on and update to Visual Studio is no longer needed. If you did install the Web Application Projects Add-on you must first uninstall it before installing Visual Studio Service Pack 1.

Visual Studio 2005 Web Application Projects


Other solution:
Install the Visual Studio 2005 Web Application Project Option (ONLY if you don't have installed Visual Studio Service Pack 1)

Regards,

Sebastian Iacomuzzi
http://staff.southworks.net/blogs/siacomuzzi